TGC ShoutBox

Refresh History
  • Forum rules apply here! Only members can Shout.
  • FLASH: Not at all! That's not even the comic book Barry Allen, but I'm ok with Ezra Miller as the Flash. Superman is more my speed these days  8)
    Yesterday at 10:17:37 AM
  • TopStarRacer: Hey FLASH! I saw Justice League the other day. How much do you relate to FLASH? :P
    December 08, 2017, 08:45:44 PM
  • JoomX: Good to see you too, Flash.  Too bad we don't have a good game we could all get into and hang out more often...
    December 08, 2017, 01:51:51 PM
  • FLASH: Long time no see Agent C! Good to see you around! BTC wished me a Happy Thanksgiving a few weeks ago so I figured I'd check in and see what's up. Hope you all are doing well!
    December 08, 2017, 01:33:09 PM
  • JoomX: Yes it would, Top.  Miss chatting with the old crew, including Dynamo.  And hey there, Agent C, good to see you...  :)
    December 04, 2017, 12:45:57 PM
  • TopStarRacer: Now if only BIG AIR and Snooog could pop in...be nice to hear from those old farts.
    December 02, 2017, 01:14:34 AM
  • TopStarRacer: The legend himself, how is the ol' AC?  Miss racing and chatting with you!
    December 02, 2017, 01:13:34 AM
  • Agent C: ;D
    December 01, 2017, 07:33:59 PM
  • Agent C: Oh, and Nintendo Switch sucks, wouldn't buy it for $50!
    December 01, 2017, 07:33:29 PM
  • Agent C: See, been that long, forgot it tells who is saying what! :P
    December 01, 2017, 07:31:55 PM
  • Agent C: Agent C, checking in after a long time. Hope everyone is doing well. I'm still around.
    December 01, 2017, 07:30:57 PM
  • JoomX: 33rd?  Wow...
    December 01, 2017, 11:42:04 AM
  • TopStarRacer: Happy 33rd Birthday Excitebike, the one that started it all!
    November 30, 2017, 11:32:16 AM
  • TopStarRacer: Happy Turkey Day Exciteboters!
    November 23, 2017, 11:37:24 AM
  • JoomX: Happy Thanksgiving, everybody...
    November 22, 2017, 08:33:56 PM
  • JoomX: Welcome to the forums, byron332...
    November 07, 2017, 12:27:57 AM
  • JoomX: Still just a sat connection, TJ.  Never going to be anything better in this area.  Over 1,000ms ping time, would totally suck trying to play online.  For EB, I'd try it though... ;)
    October 19, 2017, 12:58:10 PM
  • theJudeAbides: Did you ever get hooked up to decent internet, Joom?  We should hop into a voice-chat some time.  I have access to a Discord channel if you're interested.
    October 18, 2017, 11:34:59 PM
  • JoomX: For now, TJ.  I keep thinking it's kind of useless now with EB gone, but keep hoping a new EB or something similar will come along.  If not, I'm sure sometime we'll have to call it a day...  :(
    October 16, 2017, 11:58:09 PM
  • theJudeAbides: Well, I'm glad you're keeping it around, Joom. :D
    October 16, 2017, 11:31:12 PM

Author Topic: Online issues and debugging thread  (Read 877 times)

0 Members and 1 Guest are viewing this topic.

Offline os_bboy

  • Rookie
  • *
  • Posts: 18
  • Karma: +4/-0
  • Let's do this!
    • View Profile
Online issues and debugging thread
« on: June 15, 2014, 01:24:15 PM »
Top Star, got your pm. Im going to start this thread for the reply, as this will be an ongoing discussion.

The first thing to know is that the server is updated often right now; occasionally the server will be down for maintenance. Sometimes we just cant connect. These times will be less frequent as time goes by. They are also aware if its always down no one will use it, so there's a balance there.

Second thing is that some fixes create other issues that have to be worked out. So they may go in and fix one thing, but it may lead to other errors. An example of this is leaderboards, lets say they got one working, but not all the parameters. If certain info is not returned even thought the framework is up, there could be an error. That would require additional debugging until all parameters were fixed. Just yesterday some TvC folks were having problems, which were identified and fixed in a few hours.

There are also fixes that may eliminate or break other working methods to connect. For example, I could not get my "usb2lan" adapter to work. I use it to hard wire my wii to my modem, for a faster more stable connection (lag can be terrible in TVC without one). Whereas Polaris thought the issue might be with Brainslug, SMT understood the issue better and saw that the usb2lan simply needed to pass "wii's connection test" in the wii settings. Ability to pass the connection test was fixed, and now you NO LONGER NEED TO USE OFFLINE NETWORK ENABLER (ONE). Even with wifi, as long as you go into your wii internet settings and do the connection test. If I load ONE after passing the connection test on my wired, the connection will fail when trying to go online.

What I need is detailed feedback from everyone. When discussing issues, give as much info as possible. Things like:
1. Was everyone able to connect?
2. Everyone connected, but matches were never made? 
3. What modes are you using, and what happens in each...FC/ Everyone/ Poker etc

Then we can take a look at each incident. Also I need to get online when you guys are. I have a debugging console that can run during a match and give insight into whats going on. I can forward any info to Polaris/ SMT-DDR and they've been great about fixes.

***If you go online please note in the shoutbox before hand***

I'll be around today, and check back in a while


Offline os_bboy

  • Rookie
  • *
  • Posts: 18
  • Karma: +4/-0
  • Let's do this!
    • View Profile
Issue 1: Some not connecting
« Reply #1 on: June 15, 2014, 01:34:03 PM »
Top Star wrote:
"So...we've hit an issue. :( It seems some of us can't connect to one another. After the first successful session (I connected and raced with No Good and Copper), a few nights later I attempted to connect and race with XcitPup and FREDDY whom were both in a lobby racing each other. I spent my time searching for a match and never connected to the two of them. We could exchange FCs and see each other in Standby in the Friend's section but always got an error when try to put our profiles in the same lobby.

This afternoon I attempted to connect with No Good and Copper again like the first test session and failed. I don't think No Good and Xcitpup could connect this afternoon either."

>>First response is updates have been made, try again. One question, are you successfully using FC's at any time? Have you tried matches in the open lobby during the same session?

Offline XcitPup

  • Rookie
  • *
  • Posts: 23
  • Karma: +5/-0
    • View Profile
Re: Online issues and debugging thread
« Reply #2 on: June 15, 2014, 04:30:48 PM »
os_bboy - Thanks for starting this thread and looking into the issue.   :) Here is what has happened so far on our end:

Freddy and I are in the same house and we are both able to:  connect, make a match with each other, and play.  However, neither one of us has been able to make a match with TopStar or No Good when they have been connected at the same time as us.  This was in regular Excite Race.  Freddy created a Friend Room and I was able to join and play, however, TopStar was not able to join.  We could see him in StandBy mode.  When TopStar created a lobby we could see his lobby and we could join, but then we got Error 86420 and could not actually connect to him.

It seems like No Good and Copper (who are also in the same house) can connect to each other, but not anyone else as well. (since the first time they connected with TopStar)

Also, when Freddy and I were both connected and playing, the server only indicated 1 player was online for ExciteRace.  I can go on in about 15 minutes for a little while if anyone is available. 


Offline TopStarRacer

  • Excite Win Junkie
  • Moderator
  • TGC Junkie
  • *
  • Posts: 2,331
  • Karma: +87/-15
  • Race on!
    • View Profile
    • TopStarRacer's YouTube Channel
Re: Online issues and debugging thread
« Reply #3 on: June 15, 2014, 05:47:51 PM »
I'll provide as much information as I can:

06/10/2014 Session
Participants: No Good, Copper, and TopStar
Location: Public Races (Excite mode): 100% connection success!
Experience:
I only raced one with No Good and Copper but everything ran 100% normal. No issues. I don't believe No Good and Copper had any issues either. Connecting and racing was a success.

06/12/2014 Session
Participants: XcitPup and FREDDY
Location: Public Races (Excite mode): 100% connection success!
Experience:
The two of them were able to get in and race. They didn't bring up having any issues. FREDDY was using the disc method and XcitPup was using the Ocarina code (USB Loader GX). Success.

06/13/2014 Session
Participants: XcitPup, FREDDY, and TopStar
Location: Public Races (Excite mode): Endless searching, some connections made
Location: Friend Rooms: Endless searching, some connections made
Experience:
XcitPup and FREDDY could connect and race with 100% success, I however could "search for a match" but could never "connect" to the two of them while they raced. I also experienced slow "logging in" times as well. XcitPup, FREDDY, and myself exchanged Friend Codes and all the codes were accepted. We could see each other in Standby mode. FREDDY creates a lobby. XcitPup was able to join with 100% success but when I attempt to join his lobby I got error code 86420. I proceeded to create a friend lobby and XcitPup and FREDDY experience the same error code.

06/14/2014 Session
Participants: No Good, Copper, and TopStar
Location: Public Races (Excite mode): Endless searching, some connections made
Location: Public Races (Poker mode): 100% connection success (No Good & Copper only)
Experience:
I attempted to reconnect with No Good and Copper after the failure with XcitPup and FREDDY to see if the online success we had was a fluke. All I did was search endlessly and could never connect with No Good. No Good and Copper could race together in both Excite and Poker.

06/15/2014 Session
Participants: XcitPup and TopStar
Location: Public Races (Excite mode): 100% connection success!
Location: Public Races (Poker mode): 100% connection success!
Location: Friend Rooms: Error code 86420, no connection made.
Experience:
Finally had connection success with XcitPup (on FREDDY's profile/Wii). However we still couldn't connect in a Friend Room. We both attempted to create a lobby and still got error 86420. Public races were a complete success though.
« Last Edit: June 15, 2014, 06:09:34 PM by TopStarRacer »

Offline XcitPup

  • Rookie
  • *
  • Posts: 23
  • Karma: +5/-0
    • View Profile
Re: Online issues and debugging thread
« Reply #4 on: June 15, 2014, 06:28:27 PM »
Great detailed report! I don't know if it matters -  but  just in case - FREDDY and I switched wii's so he has the one with the USB Loader and I have the game disc.

Offline XcitPup

  • Rookie
  • *
  • Posts: 23
  • Karma: +5/-0
    • View Profile
Re: Online issues and debugging thread
« Reply #5 on: June 16, 2014, 10:05:39 PM »
Maybe we can try finding a time when we can all try getting on together.  We are available most evenings after 5p.m. West Coast time.

Offline No Good

  • bad cicada
  • Full Member
  • ***
  • Posts: 189
  • Karma: +22/-4
    • View Profile
Re: Online issues and debugging thread
« Reply #6 on: June 18, 2014, 04:23:49 AM »
Sorry I missed this on Sunday. Glad to see that there was at least some success. We are getting ready for a cross country road trip, so we won't be around much for at least a few weeks.